[Resuelto] ZX-Go+ brickeado

Dudas, cuestiones, sugerencias y peticiones en general sobre el proyecto / Questions and requests about the project
Responder
Kokopalen
Mensajes: 26
Registrado: 10 Dic 2016, 12:04

[Resuelto] ZX-Go+ brickeado

Mensaje por Kokopalen » 28 Sep 2020, 19:25

Hola a todos!

Pues tras un tiempo sin actualizarme, decidí dedicar la tarde de ayer a actualizar mi ZX-Go+ al completo (firmware, cores, ZxUnoPS2, ...) y echar unas partidas. Desgraciadamente me quedé en el primer punto :tepego:

Ya tenía todo actualizado (con el último core de spectrum funcionando) excepto la BIOS que creo que estaba en la 0.76. Al actualizar a la 0.82 se brickeó. Tras eso he comprobado que el CRC del archivo que metí en la SD no es el mismo que el que había descargado, que aún tenía en el PC (al copiar el fichero se ha debido corromper). Vamos, que a saber qué he metido como firmware en el Go+. El resultado es que ahora al encender se me queda en la pantalla "ZX-UNO Spectrum core is loaded. Now trying to boot from BIOS. You shouldn't see this screen fro more than half a second".

He estado buscando métodos de desbrickeo y creo que me tocará comprar algún cable (USB Blaster o el de la Pi), pero antes quiero ver si soy capaz de cargar la BIOS vía EAR.

El caso es que no veo ninguna respuesta (líneas o cambio de color en el borde) que respondan a la carga. Y, lo que es peor, si enciendo el Go+ y espero cosa de medio minuto sin hacer nada, la pantalla empieza a corromperse. Esto es normal?

Alguna sugerencia? Me olvido del EAR, cruzo los dedos y voy mirando cómo desbrickear con cable?

Cualquier ayuda es bienvenida!
Última edición por Kokopalen el 03 Oct 2020, 00:47, editado 1 vez en total.

Kokopalen
Mensajes: 26
Registrado: 10 Dic 2016, 12:04

Re: ZX-Go+ brickeado

Mensaje por Kokopalen » 28 Sep 2020, 22:24

Creo que va a ser más serio de lo que pensaba...

He conectado un joystick y arrancando con Joystick Arriba + Disparo me entra en la BIOS (0.78). El teclado no funciona y con el joystick sólo me deja moverme por el menú de los upgrades (upgrade ESXDOS, BIOS, Spectrum, si intento irme a derecha o izquierda no va a ningún sitio). Si quiero actualizar algo por la SD no me detecta nada (me dice not found or bad size), pero por EAR sí, así que parece que puedo actualizar la BIOS.

Lo hago usando el firmware.tap del compañero desUBIKado (de la guía http://desubikado.sytes.net/zx-uno-faq- ... o/#unbrick) y, aunque el método es distinto (yo uso el joystick para entrar en la BIOS y luego actualizar por EAR), no tengo problemas para actualizarla: cuando termina me dice BIOS upgraded. Da igual, si reinicio me vuelve a la pantalla de colores que no debería ver por más de medio segundo.

En fin, algún alma caritativa puede orientarme un poco? :temblando:

Avatar de Usuario
desUBIKado
Mensajes: 903
Registrado: 05 Ago 2016, 22:33

Re: ZX-Go+ brickeado

Mensaje por desUBIKado » 29 Sep 2020, 19:47

Según las instrucciones de las FAQ en la SD debes tener el fichero FIRMWARE.ZX1 en la carpeta raíz con el firmware que quieres grabar (yo ahora estoy usando el 0.82 sin problemas), y cargar por audio el FIRMWARE.TAP (por ejemplo el que hay para descargar en las FAQ). Si has seguido las instrucciones y terminada la carga por audio pulsas F2 para entrar en la BIOS y actualizas el firmware y te sigue pasando lo mismo, quizás puedas actualizar en su lugar la FLASH entera. Para eso pon el fichero FLASH.ZX1 de mi compilación de agosto (https://mega.nz/#!at5zRbBB!NJtRTzda90hd ... JD6XykViLY) en la raíz de la SD y actualiza la flash entera (cores, roms, BIOS y esxDOS).

Kokopalen
Mensajes: 26
Registrado: 10 Dic 2016, 12:04

Re: ZX-Go+ brickeado

Mensaje por Kokopalen » 29 Sep 2020, 20:54

Hola, desUBIKado,

Pues justo después de instalar tu imagen (por cierto, grandísimo trabajo), al ir a actualizar al último firmware, es cuando se me brickeó (ojo, la instalación de tu imagen fue perfecta y me funcionaba bien, la cuestión es que el FIRMWARE.ZX1 que copié a continuación debía estar corrupto).

Por resumir la situación actual:
- Si arranco sin más entro en la pantalla de test (la de colores).
- Puedo entrar en la BIOS si arranco con Joystick arriba + disparo o Joystick abajo + disparo. Me dice que estoy en la versión 0.78.
- Si en la BIOS intento actualizar directamente usando la SD me dice que no la encuentra o que tiene un tamaño incorrecto.
- Sin embargo, sí puedo actualizar la BIOS a través de EAR. No necesito estar pendiente de pulsar F2 ni nada tras la carga (por cierto, estoy usando un Zx-Go+) porque cuando acaba me dice "BIOS upgraded, press a key to return" y tras eso continúo en la BIOS.
- Si después de cargar la BIOS por EAR intento hacer upgrade de la BIOS desde la SD me dice "Be quiet, avoid brick" pero se queda ahí sin avanzar. Si intento hacer flash desde la SD me dice partition error (!).
- Los archivos que cargo son el firmware.tap que tienes en tu guía de desbrickeo y pongo en la raíz de la SD el FIRMWARE.ZX1 y FLASH.ZX1 de tu imagen (los que están en el enlace de mega de tu post).
- He probado con otra tarjeta sd y los resultados son los mismos.

Mirando el hilo de la actualización conjunta de la versión 0.75 me viene la duda de si el firmware.tap será de una versión anterior o tendrá algo que ver.

Me llama mucho la atención que sí pueda cargar la BIOS a través de EAR, que no me de ningún mensaje de error (al revés, me dice que la ha actualizado) pero luego no consiga nada. Es posible que tenga que cargar un FIRMWARE.ZX1 específico? Es necesario que existe algún archivo más en la SD (por ejemplo, de ESXDOS)?

Gracias por la ayuda! A ver si hay suerte y con vuestros consejos consigo que vuelva a la vida!

Kokopalen
Mensajes: 26
Registrado: 10 Dic 2016, 12:04

Re: ZX-Go+ brickeado

Mensaje por Kokopalen » 02 Oct 2020, 00:11

Bueno, bueno, estoy empezando a creer en brujas... :alienn:

La buena noticia es que he sido capaz de revivir el ZX-Go+, aunque para ello he tenido que hacer el debrick con la Raspberry (igual el firmware que se carga por EAR no es de las últimas versiones y tiene problemas con mis SD's?). El caso es que con la Pi el debrick va perfecto y vuelve a la vida.

La mala noticia es que he vuelto a caer en las mismas! :tepego:

El FLASH.ZX1 que he usado era el de tu imagen, desUBIKado, y todo iba perfecto. Lo que no he hecho es el paso del .corclean porque no sé cuál es la combinación de teclas del Zx-Go+ para pulsar / y ESC y además no veía caracteres raros en la BIOS.

Después he actualizado a la BIOS 0.82 con el FIRMWARE.ZX1 adecuado (el que pones en el hilo). He comprobado muy bien el CRC que tenía en la tarjeta antes de meterlo en el Go+ y el proceso de actualización ha sido bueno y sin errores... hasta que he reiniciado. Otra vez pantalla de test y cuando he mirado la SD de vuelta en mi pc, el CRC del archivo ha cambiado!

No sé qué ocurre, quizás es algo específico del Zx-Go+ que no va bien con el firmware nuevo? Mañana voy a volver a debrickearlo, voy a instalar tu imagen y me voy a quedar en la BIOS 0.76 por un tiempo y a disfrutar de todos esos cores!! (bueno, y a actualizar el zxunops2, toco madera!).

Un saludo!

Avatar de Usuario
desUBIKado
Mensajes: 903
Registrado: 05 Ago 2016, 22:33

Re: ZX-Go+ brickeado

Mensaje por desUBIKado » 02 Oct 2020, 00:27

Kokopalen escribió:
02 Oct 2020, 00:11
Bueno, bueno, estoy empezando a creer en brujas... :alienn:

La buena noticia es que he sido capaz de revivir el ZX-Go+, aunque para ello he tenido que hacer el debrick con la Raspberry (igual el firmware que se carga por EAR no es de las últimas versiones y tiene problemas con mis SD's?). El caso es que con la Pi el debrick va perfecto y vuelve a la vida.

La mala noticia es que he vuelto a caer en las mismas! :tepego:

El FLASH.ZX1 que he usado era el de tu imagen, desUBIKado, y todo iba perfecto. Lo que no he hecho es el paso del .corclean porque no sé cuál es la combinación de teclas del Zx-Go+ para pulsar / y ESC y además no veía caracteres raros en la BIOS.

Después he actualizado a la BIOS 0.82 con el FIRMWARE.ZX1 adecuado (el que pones en el hilo). He comprobado muy bien el CRC que tenía en la tarjeta antes de meterlo en el Go+ y el proceso de actualización ha sido bueno y sin errores... hasta que he reiniciado. Otra vez pantalla de test y cuando he mirado la SD de vuelta en mi pc, el CRC del archivo ha cambiado!

No sé qué ocurre, quizás es algo específico del Zx-Go+ que no va bien con el firmware nuevo? Mañana voy a volver a debrickearlo, voy a instalar tu imagen y me voy a quedar en la BIOS 0.76 por un tiempo y a disfrutar de todos esos cores!! (bueno, y a actualizar el zxunops2, toco madera!).

Un saludo!
Mañana te paso el FLASH.ZX1 de mi ZX GO+ que tiene la BIOS 0.82

Avatar de Usuario
spark2k06
Mensajes: 1150
Registrado: 12 Feb 2016, 13:58

Re: ZX-Go+ brickeado

Mensaje por spark2k06 » 02 Oct 2020, 12:51

Suerte! Para la actualización de ZXUnoPS2 ya sabrás que tienes dos sabores, como con la fanta o el KAS, depende del que más te guste...

Avatar de Usuario
desUBIKado
Mensajes: 903
Registrado: 05 Ago 2016, 22:33

Re: ZX-Go+ brickeado

Mensaje por desUBIKado » 02 Oct 2020, 20:37

Dejo aquí el fichero FLASH.ZX1 recién descargado de la SPI Flash de mi ZX GO+ (esxDOS 0.8.8 y BIOS 0.82)
FLASH.ZX1.7z
(3.93 MiB) Descargado 13 veces

Kokopalen
Mensajes: 26
Registrado: 10 Dic 2016, 12:04

Re: ZX-Go+ brickeado

Mensaje por Kokopalen » 03 Oct 2020, 00:45

desUBIKado escribió:
02 Oct 2020, 20:37
Dejo aquí el fichero FLASH.ZX1 recién descargado de la SPI Flash de mi ZX GO+ (esxDOS 0.8.8 y BIOS 0.82)
No sabes cómo te lo agradezco, desUBIKado! Sé que me hubiera dado mucha rabia saber que hay una versión más actual y no haber sido capaz de instalarla! :lol: He flasheado tu archivo desde el recovery y por fin tengo el ZX Go+ desbrickeado y actualizado a la última versión!
spark2k06 escribió:
02 Oct 2020, 12:51
Suerte! Para la actualización de ZXUnoPS2 ya sabrás que tienes dos sabores, como con la fanta o el KAS, depende del que más te guste...
Pues ya he aprovechado y también he actualizado al firmware alternativo, además con las modificaciones de desUBIKado para tener el mismo orden de cores y teclados (me estoy poniendo al día con todas las novedades, que son muchas!). La versión que me da es 26.09.2020 R2, desde luego no podría tener un Spectrum más al día!

Muchas gracias a los dos, porque os habéis pegado un curro enorme :maestro:. Que sepais que le voy a dar un muy buen uso!

Responder