Flashing UART core

Responder
nihirash
Mensajes: 104
Registrado: 04 May 2019, 00:55
Contactar:

Flashing UART core

Mensaje por nihirash » 27 May 2019, 22:26

Hello!

I've received ZX-Uno and tried to flash Core with uart support.
I've downloaded from topic abount YomboFTP EXP26 version of core. Renamed as CORE2.ZX1 and flashed it via BIOS. But it goes to endless reboot cycle.

ZX-Uno 4.2 with 512K ram.
My hardware:
ZX Uno 4.2, +UNO, ZX-Evolution Rev. C+VDac+ZXM-SoundCard Extreme+ZiFi, Harlequin 128K, Reverse U8, Leningrad 48K

My blog(and there gopher server on 70th port): https://nihirash.net/

Avatar de Usuario
antoniovillena
Mensajes: 2600
Registrado: 27 Sep 2015, 20:41

Re: Flashing UART core

Mensaje por antoniovillena » 28 May 2019, 00:08

nihirash escribió:Hello!
But it goes to endless reboot cycle.
This endless reboot cycle is normal. You must choose the core manually. There is no way to avoid this endless cycle without replacing the main zx spectrum core.

nihirash
Mensajes: 104
Registrado: 04 May 2019, 00:55
Contactar:

Re: Flashing UART core

Mensaje por nihirash » 28 May 2019, 00:11

antoniovillena escribió:
nihirash escribió:Hello!
But it goes to endless reboot cycle.
This endless reboot cycle is normal. You must choose the core manually. There is no way to avoid this endless cycle without replacing the main zx spectrum core.
I've selected it from bios. I think in my experiments i've downgraded even main speccy core :?

I've cloned your repo zxuno and tried to make full flash image "flash.zx1" with replaced one core to Uart-supported. :D

I think there some goes wrong :lol:
My hardware:
ZX Uno 4.2, +UNO, ZX-Evolution Rev. C+VDac+ZXM-SoundCard Extreme+ZiFi, Harlequin 128K, Reverse U8, Leningrad 48K

My blog(and there gopher server on 70th port): https://nihirash.net/

Responder