MIST AGA funcionando en placa UnAmiga

Otras placas, clones o aparatos basados en FPGA / Oher FPGA based clones/devices/boards
Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por Dotoro » 14 Ago 2018, 21:50

Thank you!
I manage to boot MiST AGA core onece per 15-20 power on,
this is very strange.

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por Dotoro » 14 Ago 2018, 21:53

jepalza escribió:Tienes que pones el conector pequeño, en los pines de 3.3v (quitando el "jumper" original)

Por cierto: diles a tus amigos del foro, que los fuentes los publicaré en breve, en cuanto organice todo el trabajo. Piensa que he hecho varios cores en poco tiempo, y no he tenido tiempo de organizar las cosas. ;)

http://zx-pk.ru/threads/29327-unamiga.html
Thank you very much Jepalza! This is great news)

Avatar de Usuario
jepalza
Mensajes: 612
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por jepalza » 14 Ago 2018, 21:55

Entiendo que dices, que tarda 15-20 segundos en arrancar: eso es normal!!!! lo explico en el hilo original. La primera vez tarda unos 20 segundos, por que necesita cargar, por un lado el menu DE1_BOOT y por otro el KICK.ROM, que juntos ocupan unos 700k, y lo carga por SPI, que es un protocolo serie bit a bit, un poco lento. Pero una vez cargado, las siguientes veces es mas rápido.

Avatar de Usuario
jepalza
Mensajes: 612
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por jepalza » 14 Ago 2018, 21:57

Dotoro escribió: Thank you very much Jepalza! This is great news)
No he dejado "codigos fuentes" porque muchas versiones, aún estoy cambiando y mejorando, y algunas tienen fallos. Cuando vea que son funcionales 100%, los dejaré , por que "no son mios", son copias de códigos que ya existen. De momento, solo he dejado los fuentes del minimig y los del next186, por que son versiones finales.

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por Dotoro » 14 Ago 2018, 22:08

Thank Jepalza! You are great and kind person thank you for your help.
I found problem at last =) its something with power, its not start when i press ON switch on altera board,
and when i turn power brick it start!
I don't know why, maybe its connected to peak start power or something.
Anyway i glad i can start MiST core, even if it takes to start it without board switch but only with power brick switch.

Avatar de Usuario
antoniovillena
Mensajes: 2600
Registrado: 27 Sep 2015, 20:41

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por antoniovillena » 14 Ago 2018, 22:54

Another picture if it helps
Adjuntos
photo_2018-08-14_15-22-55.jpg

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por Dotoro » 14 Ago 2018, 23:07

antoniovillena escribió:Another picture if it helps
Thank you.

Avatar de Usuario
antoniovillena
Mensajes: 2600
Registrado: 27 Sep 2015, 20:41

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por antoniovillena » 14 Ago 2018, 23:29

I have read a little this thread (with google translate):

http://zx-pk.ru/threads/29327-unamiga.html

I won't publish the gerber but there is no problem for the schematics attached. You can share in the russian forum. About the cores I don't make them or have access to the sources, but some of them are published here.
Adjuntos
jepalzafull.pdf
(34.37 KiB) Descargado 280 veces

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por Dotoro » 15 Ago 2018, 00:08

antoniovillena escribió:I have read a little this thread (with google translate):

http://zx-pk.ru/threads/29327-unamiga.html

I won't publish the gerber but there is no problem for the schematics attached. You can share in the russian forum. About the cores I don't make them or have access to the sources, but some of them are published here.
Thank you very much! :chocala!: :D

Avatar de Usuario
jepalza
Mensajes: 612
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensaje por jepalza » 23 Ago 2018, 21:34

debido a la creación del nuevo foro especializado en FPGA en español que ha creado mcleod_ideafix, en concreto http://www.forofpga.es , las nuevas actualizaciones y cores, las publicaré allí. Este es el foro ZXUNO, y ya he leído críticas sobre el uso del foro exclusivo ZXUNO para el UnAmiga. Ademas, mantener dos foros para explicar lo mismo, es un lío.

Dicho esto: he actualizado el core MIST AGA a la versión 5, con una mejora en el teclado, que permite sacar el caracter "\" que antes no se podía. Se puede descargar en el apartado exclusivo UnAmiga --> http://unamiga.forofpga.es

Responder