Ayuda con AUTOBOOT.BAS

Discursiones en general sobre el proyecto que no tienen cabida en otro foro / General discussion for uncateorized topics about the ZX-Uno project
Vanfanel
Mensajes: 252
Registrado: 16 Oct 2016, 15:50

Ayuda con AUTOBOOT.BAS

Mensajepor Vanfanel » 20 Sep 2018, 16:27

Hola gente,

Hoy he actualizado mi ZX-UNO a ESXDOS 0.86 final, que al fin trae soporte para ejecutar en el arranque un fichero que debe ser SYS/AUTOBOOT.BAS

El problema es que a mi no me funciona. Por ejemplo, si mi SYS/AUTOBOOT.BAS tiene como contenido:

10 .ls

pues debería mostrar el contenido del raiz de la SD nada más arrancar, pero lo único que hace es cargar el AUTOBOOT.BAS, no lo ejecuta.
Entonces, ¿Alguien sabe cómo decirle al ESXDOS que no sólo lo cargue sino que además lo ejecute?

Y otra cosa: ¿hay algún comando para entrar directamente al navegador NMI? Para ponerlo en el AUTOBOOT.BAS y que mi ZX-UNO arranque en el menú NMI, que soporta joystick y todo!

Avatar de Usuario
Uto
Mensajes: 1368
Registrado: 17 Dic 2015, 16:39

Re: Ayuda con AUTOBOOT.BAS

Mensajepor Uto » 20 Sep 2018, 19:20

¿Como has grabado el autoboot.bas?

El proceso correcto es

1) Desde basic (48K, no sé si va con el de 128K) tecleas el programa
2) .cd /SYS
3) SAVE * "AUTOBOOT.BAS" LINE 10

Si tu programa basic empieza en otra linea cambia el LINE 10 por la linea que sea.

Respecto a entrar en el menu NMI:

Código: Seleccionar todo

RANDOMIZE USR 102

Avatar de Usuario
desUBIKado
Mensajes: 595
Registrado: 05 Ago 2016, 22:33

Re: Ayuda con AUTOBOOT.BAS

Mensajepor desUBIKado » 20 Sep 2018, 19:22

Mira a ver como tienes el fichero /SYS/CONFIG/ESXDOS.CFG

viewtopic.php?f=27&t=2091&p=23446&hilit=Esxdos+0.8.6#p23430

Vanfanel
Mensajes: 252
Registrado: 16 Oct 2016, 15:50

Re: Ayuda con AUTOBOOT.BAS

Mensajepor Vanfanel » 20 Sep 2018, 20:16

@desUBIKado: lo tengo correctamente congurado para que ejecute el SYS/AUTOBOOT.BAS cada vez que se inicia en frio o en caliente.

@Uto: Todo me lo deja hacer hasta la línea del SAVE, ya que no le gusta eso de LINE 10, como si le sobrase... He probado a arrancar con ROMs de 48K y nada, no le gusta eso. ¿Tienes idea de qué puede pasar? ¿Eso de LINE 10 es para indicarle dónde tiene que empezar a ejecutar el programa?

Avatar de Usuario
desUBIKado
Mensajes: 595
Registrado: 05 Ago 2016, 22:33

Re: Ayuda con AUTOBOOT.BAS

Mensajepor desUBIKado » 20 Sep 2018, 21:00

El LINE es un token, no se escribe letra a letra

Vanfanel
Mensajes: 252
Registrado: 16 Oct 2016, 15:50

Re: Ayuda con AUTOBOOT.BAS

Mensajepor Vanfanel » 20 Sep 2018, 22:33

@desUBIKado: Ya está, ya lo tengo todo funcionando a mi gusto. Gracias!
Menudo bruto... Si es que yo de chico no me conocía tantos tokens de zx basic... Y eso que ahora tengo un GO+, pero lo mio con ese teclado es una relación de amor / odio muy tormentosa :D

Avatar de Usuario
desUBIKado
Mensajes: 595
Registrado: 05 Ago 2016, 22:33

Re: Ayuda con AUTOBOOT.BAS

Mensajepor desUBIKado » 21 Sep 2018, 08:25

Felicidades. Hay roms alternativas que permiten introducir todo letra a letra o cambiar al modo tradicional con tokens, como la Derby++ o la Looking Glass

viewtopic.php?f=27&t=2091&p=23461#p23501

Vanfanel
Mensajes: 252
Registrado: 16 Oct 2016, 15:50

Re: Ayuda con AUTOBOOT.BAS

Mensajepor Vanfanel » 22 Sep 2018, 16:42

@desUBIKado: Sí! De hecho, uso precisamente tu paquete de ROMs :)


Volver a “General / Uncategorized”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados