bad flash problem

Discursiones en general sobre el proyecto que no tienen cabida en otro foro / General discussion for uncateorized topics about the ZX-Uno project
Mensajes: 13
Registrado: 02 Ago 2018, 08:21

bad flash problem

Mensajepor byrtolet » 02 Ago 2018, 08:38


recently I tried to upgrade my zxuno with the file FLASH.ZX1 from the official download page. I believe it is version 4.1.

After a "successful" flash, the zxuno booted the last selected default core, but the boot menu & setup didn't work (after pressing esc or f2 made my zxuno frozen).

Since I have xilinx platform cable I thought I could debrick my zxuno.
I tried so. I used recovery.73.bit found somewhere on the net.
After unsuccessful attempts with the above FLASH.ZX1 ( it gave bad partition or file size).
I used other recovery.bit and managed to flash the abovementioned file. After that the zxuno booted with a colorful screen saying that I should not be able to see that screen!

I found another FLASH.ZX1 file with size 16MB. I flashed it with recovery.73.bit succesfuly this time.
After that my zxuno displays black screen (both with composite & VGA outputs).

I'm still able to load recovery bitstream file so the board is semiworking.

How can I fix my zxuno? Is there any .mcs file I could use?

Please explain me what are exactly FLASH.ZX1, FIRMWARE.ZX1, etc - I'm not sure what is what. I don't understand zxuno boot architecture.
I'll be glad if you point me to some docs describing this.

Where do I find working firmwares & recovery files?

What is current zxuno repository I found a subversion and another git one?

At the end I have to say that I think zxuno is great piece of tech! I want to thank all people involved in its design & development.

Thank you!

Avatar de Usuario
Mensajes: 2
Registrado: 02 Jun 2018, 21:48

Re: bad flash problem

Mensajepor nmmgp » 05 Ago 2018, 13:54


First you should test the hardware to check if everything is OK.

For this you can use the following bit file:

If your board has 512KB of RAM: ... rod_v4.bit

If your board has 2MB of RAM: ... rod_v4.bit

If the hardware is OK use the following recovery bit file: ... ery.73.bit

Then copy the following file to a SD Card an place it on the ZX-UNO: ... /FLASH.ZX1

Now you can flash your ZX-UNO with the file that is on the SD card. At the end your UNO should work fine.

Mensajes: 13
Registrado: 02 Ago 2018, 08:21

Re: bad flash problem

Mensajepor byrtolet » 06 Ago 2018, 15:53

Thank you. Now it works!

Volver a “General / Uncategorized”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados