Cable Recovery

Todo aquello que acompaña a la placa del ZX-Uno (carcasas, alimentadores, pegatinas para el teclado, etc) / Everything that goes with the ZX-Uno board (cases, AC adapters, stickers for keyboard, etc)
Avatar de Usuario
DistWave
Mensajes: 182
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Cable Recovery

Mensaje por DistWave » 27 May 2016, 10:42

Pues no he conseguido hacerlo funcionar:
- Ahora al cargar el .bit aparece el firmware. No salen campos vacíos ni corruptos, parece como si los cores estuviesen grabados pero no arranca ninguno.
- Al actualizar la flash desde la SD ocurre lo mismo que antes, se completa el proceso sin dar ningun error pero al quitar la corriente no arranca.
- Cargando por EAR el firmware se comporta de la misma forma.
- Al intentar actualizar el core de Spectrum desde la SD se queda colgado con el Status vacío.

EDIT: Por alguna extraña razón, ahora el prototipo arranca! No he vuelto a grabar la flash y funcionan las roms de spectrum. Lo que no van son el resto de cores, ni me deja actualizarlos via SD (al intentarlo salta a la pantalla de "Press PLAY or SPACE to break" del cargandoleches)

EDIT2: No solo son los cores, al intentar actualizar la flash también salta, aunque ahora en vez de mostrar el mensaje del cargandoleches directamente sale basura de colores en el paper.
Última edición por DistWave el 27 May 2016, 11:05, editado 2 veces en total.

Avatar de Usuario
antoniovillena
Mensajes: 2599
Registrado: 27 Sep 2015, 20:41

Re: Cable Recovery

Mensaje por antoniovillena » 27 May 2016, 11:01

Qué raro. Pues yo lo he probado varias veces y me funciona. No lo he hecho con el cable de 3.5€ de Altera porque tardará en llegarme, pero sí con mi JTAG Xilinx. Lo he probado con un v4.1 (vale también un v4) con la SPI completamente borrada (QE=0). Los pasos que he hecho son:
  1. Cargo el .bit del zip desde el cable JTAG, manteniendo pulsado arriba y disparo en el joystick.
  2. Le meto por EAR el .tap del zip por carga estándar.
  3. Cuando acabo la carga se me posiciona justo en la opción de grabar flash, así que pulso Enter y le doy a Yes. En ese momento hay una SD metida con el FLASH.ZX1 que quiero grabar.
  4. Al realimentar ya tengo la flash completamente recuperada del archivo FLASH.ZX1, con QE=1 y arrancando perfectamente.

Avatar de Usuario
antoniovillena
Mensajes: 2599
Registrado: 27 Sep 2015, 20:41

Re: Cable Recovery

Mensaje por antoniovillena » 27 May 2016, 11:03

DistWave escribió:
EDIT: Por alguna extraña razón, ahora el prototipo arranca! No he vuelto a grabar la flash y funcionan las roms de spectrum. Lo que no van son el resto de cores, ni me deja actualizarlos via SD (al intentarlo salta a la pantalla de "Press PLAY or SPACE to break" del cargandoleches)

EDIT2: No solo son los cores, al intentar actualizar la flash también salta, aunque ahora en vez de mostrar el mensaje del cargandoleches directamente sale basura de colores en el paper.
Asegúrate de que tienes la SPI Flash completamente borrada desde la opción Erase de iMPact. Así te evitas falsos positivos.

Avatar de Usuario
DistWave
Mensajes: 182
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Cable Recovery

Mensaje por DistWave » 27 May 2016, 11:06

No tengo el cable Xilinx y por tanto no puedo usar iMPact, voy a repetir el proceso desde el principio.

Avatar de Usuario
antoniovillena
Mensajes: 2599
Registrado: 27 Sep 2015, 20:41

Re: Cable Recovery

Mensaje por antoniovillena » 27 May 2016, 11:09

DistWave escribió: - Ahora al cargar el .bit aparece el firmware
Esto no debe pasar. El .bit contiene un bootloader que normalmente carga el firmware de la SPI, exista o no firmware. Con la combinación Arriba+Disparo en el joystick salta a otra rutina que en lugar de cargar el firmware desde SPI lo hace desde cinta.

Avatar de Usuario
antoniovillena
Mensajes: 2599
Registrado: 27 Sep 2015, 20:41

Re: Cable Recovery

Mensaje por antoniovillena » 27 May 2016, 11:13

DistWave escribió:No tengo el cable Xilinx y por tanto no puedo usar iMPact, voy a repetir el proceso desde el principio.
Ah vale. No lo sabía. Con tu cable debería funcionar. Siguiendo el proceso se machaca toda la Flash. Al hacer Erase te aseguras al 100% que funciona, ya que podrías tener la FLASH casi grabada de antes y que el proceso te funcione por otros motivos. Durante la carga en cinta, ¿ves una especie de carta de ajuste?

Avatar de Usuario
DistWave
Mensajes: 182
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Cable Recovery

Mensaje por DistWave » 27 May 2016, 11:16

Cargando este ultimo .bit si que aparece esa pantalla. Creo que ahora se ha grabado bien, pero a lo mejor estoy metiendo un FLASH.ZX1 viejo porque luego no puedo actualizar los cores...

Avatar de Usuario
antoniovillena
Mensajes: 2599
Registrado: 27 Sep 2015, 20:41

Re: Cable Recovery

Mensaje por antoniovillena » 27 May 2016, 11:20

Este es el más nuevo que tengo. Los cores no necesitas actualizarlos ya que están incluidos en el mismo flash. ¿Cómo intentas actualizar los cores, por EAR o SD?
Adjuntos
flash.zip
(1010.07 KiB) Descargado 74 veces

Avatar de Usuario
DistWave
Mensajes: 182
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Cable Recovery

Mensaje por DistWave » 27 May 2016, 11:46

Por SD, pero con este FLASH.ZX1 ya funciona todo bien. Me atrevo a decir que este método ya es completamente efectivo para resucitar un zx-uno con el jtag USB-Blaster de Altera.

Avatar de Usuario
antoniovillena
Mensajes: 2599
Registrado: 27 Sep 2015, 20:41

Re: Cable Recovery

Mensaje por antoniovillena » 27 May 2016, 11:51

DistWave escribió:Por SD, pero con este FLASH.ZX1 ya funciona todo bien. Me atrevo a decir que este método ya es completamente efectivo para resucitar un zx-uno con el jtag USB-Blaster de Altera.
Genial. Muchas gracias por tu ayuda. Entonces a partir de ahora incluiré un trozo de cable microJST en los ZX-Unos que venda. Así el que quiera comprarse el USB Blaster, que lo pida por su cuenta y no tendrá más que conectarlo a dicho cable.

Responder